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VIN projekt - VP4: STM32-CubelDE projekt,
breadboard vezave

AOsvegitev: STM32H7 sistem

A Priprava na povezovanje

A STM32H7 CubelDE + breadboard povezave
A LED, tipka, potenciometer, uporovna tipala

A DN2-VP4: Breadboard + STM32H7
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A Priprava na povezovanje

A STM32H7 CubelDE + breadboard povezave
A LED, tipka, potenciometer, uporovna tipala
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STM32H750B 1 DISCOVERY StMod + konektor
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https://www.st.com/en/evaluation-tools/stm32h750b-dk.html
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STM32H750B 1 DISCOVERY StMod + konektor

Mikrobus connectors

3.3V Il

—  Socket 8x1 Socket 8x1

CNII CN10
STMOD#13 L | AN Pwm STMOD#14 1
(S STMOD#12 5 | RST mWrT STMODI1 )
<f g 3 STMOD#1 51 ¢ Rx STMOD#3 3
e vy STMOD#4 4 | SCK TX STMOD#2 3
sko e STMOD#9 s | miso scL STMOD#7 5
=W < STMOD#8 MOS! SDA STMOD#10
efloF a ) S 1 +33v +5v -, g
% 3V3—— 7| a0 anp sV —— 7
-~ —

sV STMod+
— PA15 SB2 Iy Pl
e PAD SBIg== 1 Socket 10X2 STMod+
— PB15 SBli—— =~ 1 PH12 - -
OD#-MOSI, 2 S 1 1o e~ STMODFIT-INT
MOD#2-TX L Bl . 2 it STMOD#12-RST
STMOD#3-MISOp FD6 SB-i ? 3 13 PA3 STMOD#13-ADC
STMOD#3-RX D3 SB {~ | | 4 a5 14 STMOD#14-PWM
STMOD#4-SCK. PD4 SBY —— ? — 3 2135
AR PD12 STMOD SCL D PH1 ST
STMOD#E-MOSE _—s— 3 18 o ODA18
STMOD#9-MISOs . : 9 19 OD#19
PD13 STMOD _SDA 10 20 PH38 OD#20
ATOM FH200210C-12000
12¢
~
AN RST, CS ,SCKMSOMOSI 33 GN STMOD SDA _ PD13

\___SLOID 1C SDA —TMoD SCL__PD12. =

'- .- l|-l . : - . - SCI
ol o g o ol ol
! ’ @ @ @ : » ‘ Testno vezje (primer) - STM32H7 :

L = B v |

GPIO Vrsta Povezava

GPIO - PH10
GPIO i PA15

ADCi PA4

N PC13 _ User tipka Modra tipka

u a0 N i N | N .- | N | | & N N |

< PA4 | Analognivhod Rumena zicka 1

Qo

L PH10  Dig. Vhod Zelena Zicka |

o

-4 PA3  Dig.lzhod - LED  |Orangna ¥icka |
PJ2,Pi13 Dig. Izhodi vgr. LED diode
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STM32H750B i DISCOVERY StMod + konektor

3.3V

AN .
GND GP2 GPO X Mikrobus connectors
Mlo o o o ‘
s CN11 CN10
A llm B o o O STMOD#13 L] AN PWM STMOD#14 :
o |l & < U o Q —o— 6 STMOD#12 , | RST INT STMOD#11 >
< == m CN1 ICH PDtih < =Z 3 STMOD#1 3| 6 RX STMOD#3 3
| afle T gt 17> = I Y o STMOD#4 4| sck T STMOD#2 ;
e w “|lslsv{dla B 9 U STMOD#9 s | Mo scL STMOD#T 5
a Ol o a oo all STMOD#8 MOS! SDA STMOD#10
L il 3 & 33— ?’ pe ol sV—— ?'
L — L L . & Y g | GND GND 4
LR ) T e, Ze b T 0 vy € | |
T T o —1 ikrobus 4 £ ~ = Socket 8xI = Socket 8xI
L PWM' INT RX 'TX 'SCL'SDA 5V 'GND 04 <Q2
- > Q\ B XX LT
l—‘ E'=' 5V STMod+
w19 o ——
[ =
v JEEle] ==
( = [ ———
O v R
/' It [ —— STMOD#-I -CTS PB15 SBEE * S o1z :
\_) [ e 71175 S 11 D o PHIO 0 —SihioDsl2 RoT
V3 O U T B3 2 M 1 B g ion PAT S TNOD# WA
= STMODFE-SCK o) a5 * — s 2
o I ——— STMOD#-RTS__—ppgz —STMOD SCL o PH1 S
H: IEI Eu = STMOD#8-MOSIs ,P,gu 8 18 m} ODZ1%
m3 5 Eg D:D:_—E= B A, PD13 STMOD SDA ?0 ;g PH8 8 3
)55 @ —t
No ATOM FH200210C-12000
) ¢ / g
4 MISOMO EI:EI::I:I_ & STMODIBC ) 7 spa —SIMOD SDA  PD13 T
AN RST, CS ,SCKMISOMOS|3V3GND S rob ,i, 1] { SDA —Shiob St oI ==
5 5 [ us v
{00 0 0 I O s § o]
"o Testno vezje (primer) - STM32H7 :
g % 5 '_‘% 2 estno vezje (primer)
SRS~ © o o] = LS
— ] — zZ| o <—'(ﬂ %2} GPIO Vrsta Povezava
olloH o (N I Q oL : ,
of z = Fi p be) W PC13 Usertﬂ(a ModraEElka
g Q 4 A A A1 &< I| PA4 | Analognivhod Rumena Zitka I
% a| 0| pH10 Dig. Vhod Zelena fitka I
@
Q S a Bnoan g ! __PA3  Dig. Izhod - LED | OranZna Jitka !
o o ""/ PJ2,Pi13 Dig. Izhodi vgr. LED diode
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STM32H750B i DISCOVERY

STM32H750VB STM32H750ZB STM32H7501B STM32H750XB

StMod + konektor

Electrical characteristics (rev Y)

3. This formula has to be applied on power supplies related to the 10 structure described by the pin definition

table.

4. To sustain a voltage higher than 4V the internal pull-up/pull-down resistors must be disabled.

Table 20. Current characteristics

Symbols Ratings Max Unit
ZIVpp Total current into sum of all Vg power lines (source)(") 620
$IVgs | Total current out of sum of all Vg ground lines (sink)(") 620
Vpp Maximum current into each Vpp power pin (source)V) 100
Vss Maximum current out of each Vgg ground pin (sink)(") 100
lio Output current sunk by any 1/0 and control pin 20
Total output current sunk by sum of all I/Os and control pins®) 140 mA
Zew) Total output current sourced by sum of all I/Os and control pins(® 140
Injected current on FT_xxx, TT_xx, RST and B pins except PA4, —5/+0
Iinggpin) @) | PAS
Injected current on PA4, PAS -0/0
Zlinypiny | Total injected current (sum of all I/Os and control pins)(5) +25

Output driving current

The GPIOs (general purpose input/outputs) can sink or source up to +8 mA, and sink or
source up to +20 mA (with a relaxed Vo /Vop).

In the user application, the number of I/O pins which can drive current must be limited to

respect the absolute maximum rating specified in Section 6.2. In particular:

VIN - LV
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N e Mi kro USB priklo
D

elo na STM32H7 razvojnem sistemu (srednjit)

Prikljulitev
A Mikro USB priklopnad al j gi strani ci (sr

Poseben zal gihab)inipfoza STMB2AH7 (
(e-ul i I nica):
A dodajanje vsebine (_main.c):

E CubelDEWorkspace - Sluzba/ORLab-STM32H7/5TM32H750B-DK_C_Basic/Core/Src/main.c - STM32Cubel DE
File Edit Source Refactor Navigate Search Project Run Window [ Help

= < |® > & v @in| Ery&E Yy Fry@rHvyP vy~ @y v JRE T HYHyoIor
& Project Explorer % BEY £ 70 Emainc  Emainc X

O CubelDE_Workspace A 131

& Delo 132 /* Infinite loop */

133 /* USER CODE BEGIN WHILE */

[ Node V4 (in node v4) 134 while (1)

v 12 Sluzba 135 {
[T CAN_IEX_Module 136 HAL_GPIO_TogglePin(GPIOI, GPIO_PIN_13);
& CAN_IEX Module_bak 137 HAL_GPIO_TogglePin(GPIOJ, GPIO_PIN_2);
nep. y 138
I H7-8SP-LCD-05 139 /* USER CODE END WHILE */
= ORlLab-5TM32 w94e . -—-————-- Razvojni sistem STM32H750-DK -----------
¥ = ORlab-STM32H7 141 /* USER CODE BEGIN 3 */
& Docs 142 snprintf (SendBuffer,BUFSIZE,"USART3:%d secs\r\n",Cnt); R ) o .
& DWT Cycles Measurements Ei HAL_UART_Transmit(&huart3,SendBuffer,strlen(SendBuffer),1); @ | STM32H750B-DK Discovery kit with STM32H750XB MCU &
GPIO_LEDs _ 145 HAL_Delay(10€0); @ | VINLab-STM32H7 - GitHub repozitorij ¢
v & STM32H750B-DK_C_Basic 146 Cntat;
v & Core 147} @ | STM32H7-online training (tutorials from ST) &
& Inc 148  /* USER CODE END 3 */
149 . N
v ‘3‘"5:@ 158 } @ | ORLab-STM32H7 - GitHub repozitorij ¢
=== ..
. L] STM32H7 - Dokumentacija ¢*
Lastni viri :

https://github.com/LAPSYLAB/STM32H7 Discovery VIN Projects

https://github.com/LAPSYyLAB/ORLab -STM32H7

VIN - LV 8 ERozman, Gkr aba,



https://github.com/LAPSyLAB/STM32H7_Discovery_VIN_Projects
https://github.com/LAPSyLAB/ORLab-STM32H7
https://github.com/LAPSyLAB/ORLab-STM32H7
https://github.com/LAPSyLAB/ORLab-STM32H7

Delo v CubelDE

[I CubelDEWorkspace - STM32CubelDE

Vzpostavi

A Uvoz

File Edit Source Refactor Navigate Search Project Run \
New Alt+Shift=N > | %
1 : E
tev zaletnega pr oj ekt openfe.
_ . Open Projects from File System...
obstojel ega I Recent Fies >
A Open projects from File System | I mportProjcts rom FeSystem o Avchive o X
i Import Projects from File System or Archive B
) ! This wizard analyzes the content of your folder or archive file to find projects and import them in the IDE.
|
A Select project(s) |
; Import source: ‘ D:\OneDrive - Univerza v Ljubljani\Delovni\Workspaces\CubelDE\STM32F4_Discovery_VIN \/‘ Directory... Archive...
[ type filter text | Select All
Folder Import as o] Deselect Al

STM32F4_Discovery VIN_Projects

A Nov projekt Cube MX

|

STM32F4_Discovery VIN_Projects\Audio_playback_and 1 Eclipse project

Edlipse project
2 of 8 selected

<

[ Hide already open projects

0]

[ Close newly imported projects upon completion
. Use installed project configurators to:

Search for nested projects

Detect an

A Kopiranje tojeleg

-

roject natures

m CubelDEWorkspace - STM32CubelDE

File Edit Source Refactor Navigate Search Project Run Window Help
HvH@ ®~]R~Eividigre~r
&2 Project Explorer 22

Prevajanje, zagon :
A Project -> Build Project

Open Project
Close Project

B Build All
> & OR

Build Configurations

& RA
Build Proje Md Proj
A Run -> Debug s s g
~ 2 STM32F4_Discovery_Projects (in STh : 9
Clean...

> & Audio_playback_and_record
> [ Buzzer PWM_Demo

» [ Initial_Breadboard_VIN

> [ LED_Blink_Demo

Build Automatically

Build Targets

A Step (Into,Over), Breakpoint

m CubelDEWorkspace - LED_Blink_Demo/Core/Src/main.c - STM32CubelDE

C/C++ Index

File Edit Source Refqmiemblaidlcite S dim roject Run Window Help [ CubelDEWorkspace—SIM32CubelDE .
‘- ey = = F'_d}, Bt e D v G ovi® 1) Edit > Copy.
g SR BiS iR % e o Ml tidie 8 “ File Edit Source Refactor Navi Search Project Run Window Help 2) Edit = P
; f = . = . N ) Edit > Paste.
4 Debug = i Project ExSTardr = Berime.txt main.c st vEHR I ® & v Bivwidigr > & @ Run 3) Bename the igs files
~ [ LED_Blink_Demo Debug [STM32 Cortex-M C/C ;Z :/@m ant & Project Explorer & % Debug 1) Delete the Debug.launsh file.
~ & LED_Blink_Demo.elf [cores: 0] 75-int main(void) ¥ = FRI Run History 5) Project > (Jeap.
b # i 3 > = O0R
o Tfreac.l 1 [malr.1] 1 [core: 0] (Suspende 76 { X T O Run As ) . 6) Generale the ubelX.
= main() at main.c:84 0x800057¢ ;; /* USER CODE BEGIN Cun Run Configurations... 7) Project > Build Project.
# arm-none-eabi-gdb (8.3.1.20191211) v ; P
& ST-LINK (ST-LINK GDE server) 79  /* USER CODE END 1 ¥ 1 STM32F4 Discovery Projects i STV32F4 DI Dzl ity g)Rﬁ@&LEAS 5tm32 Application.
8e > & Audio_playback_and_record Delingg A ) i )Anddﬂbugﬁlﬁ ﬁﬂm
81 /* MCU Configuratio » [ Buzzer PWM Dermo Debug Configurations...
82 N N

> [ Initial_Breadboard_VIN
> [ LED_Blink_Demo

Breakpoint Types
Toggle Breakpoint

Br gt g 211 per
8 HAL_Init( ;l
S
/* USER CODE BEGIN

Ctrl+B

Navodila :
* CubelDE asm projekt

1) Edit > Copy.
2) Edit > Paste.
3) Delete the Debhuglaungh file.
4) Project > (Jgap.
5) Project > Byild Project.
6) Debug As Stm32 Application.
7) And debug the aprlisation

> 8) Add hreaknaint on first instuction if nesessary

>

* CubelDE projekt z CubeMX

Skopiram, preimenujem, generiram jog, ¢lean in build

/* USER CODE END In

/* Configure the sy
- —— -‘..:: .t

Toggle Breakpoint
- s e mm o

ERozman, Gkr aba,
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VIN projekt - VP5: STM32- CubeIDE prOJekt
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breadboard vezave B svs 2 LB delo istine, mavodila .
AOsvegitev: STIE em

[ A Priprava na povezovanje }

A STM32H7 CubelDE + breadboard povezave
A LED, tipka, potenciometer, uporovna tipala

A DN2-VP4: Breadboard + STM32H7
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Breadboard vezava

Uporovna tipala

LDR 1 Light Dependent Resistor PGM5337
FOTO UPOR PGM5537 100mW 16-50kR 540nm

D> Electronics Characteristics

Vi Pmax Ambient Spectral Photo Dark ResponseTime
Model ax . Temp Peak Resistance Resistance i (ms)
(VDC) | (mW) 9 . min :
(°C) (nm) (10Lx) (KQ) (MQ)min Rise Decay

PGMS5506 100 90 -30~+70 540 2~6 0.15 0.6 30 40

PGMS5516 100 90 -30 ~ +70 540 5~10 0.2 0.6 30 40
'l-Iw‘w--l-]m--]m--_m#m-l-ﬂo_-l-&mﬂ-- --m---%-I-JL---&-I‘
| PGMS5537 150 100 -30 ~ +70 540 16 ~ 50 20 0.7 20 30 |
.--------------l---------l-----------------------J

< TOKEN

PGM CDS Photoresistors

VIN projekt - VP3: STM32-Cub...

’ Terminology

e Light Resistance :
Measured at 10 lux with standard light A
(2854K-color temperature) and 2hr.
preillumination at 400-600 lux prior testing.

® Dark Resistance :
Measured at 10th seconds after closing 10 lux.

o Gamma characteristic :

Sensitive surface

Ceramic substrate

Resin Encapsulation

Lead wires

Co

Electrodes

nducting resin

Under 10 lux and 100 lux and given by y = log(R10/R100) / log(100/10) = log(R10/R100)

R10, R100: resistance at 10 lux and 100 lux.
The tolerance of vy is £0.1.

® Pmax :
Max. power dissipation at ambient
temperature of 25°C. At higher ambient
temperature,the maximum power permissible
may be lowered.

® Vmax :
Max. voltage in darkness that may be
applied to the device continuously.

® Spectral peak :
\V, in accordance with figure ‘Spectral Response’.
The tolerance of spectral peak is £50nm.

Relative sensitivity(%)

100 Cds
0 VA
CdSg
60 /\ \‘r
40 / \ Cd(§.S¢e)
-
20
0 —
400 500 600 700 800 900 1000
‘Wavelength(nm)

Spectral sensitivity of photoresistors depends on the wavelength of light they are exposed to and

Sensitive surface

Ceramic substrate

Resin Encapsulation

Lead wires

Electrodes

Conducting resin

ERozman, Gkr aba,



Breadboard vezava

UPOR NTC 2K2 5% \

N\

Uporovna tipala NTCC-2K2 SR PASSIVES
NTC T Termistor NTCC-2K2  NTC thermistor; 2.2kD; THT; 3900K; -55 125 C; 500mW;
R25 = 2.2k0) B25/50 = 3950K 9 K Y§aa
TC | RkQ | T°C | REQ | T°C | Rk | TC | RkQ | T°C | Rka | T°C | Rka E ol B ()
a0 | 40.128 | -4 8.871 22 2511 48 | 0.857 74 0341 | 100 | 0.154 @ﬁ'm@_' — — — :
29 | 37694 | -3 | 8415 | 23 | 2a02 | 49 | 0824 | 75 | 033 | 101 | 0154 “\-\ :
28 | 35418 | -2 | 7986 | 24 | 2208 | s0 | o794 | 76 | o318 | 102 | 015 b W
27 | 33289 | -1 | 7581 | 25 2.2 s1 | o7ed | 77 | 0308 | 103 | 0.148 N | - Lo°1
26 | 31298 | o | vz3e | 26 | z10s | s2 | o736 | 78 03 | w04 | 0142 .
25 | 29436 | 1 | 6839 | 27 | 2016 | 53 | ovos | 79 | o028 | 105 | 0139 i T
24 | 27893 | 2 | 6499 | 28 | 1931 | s4 | 0683 | 80 | o281 | 106 | 0135 [
23 | 26064 | 3 | 6179 | 29 | 185 | s5 | 0659 | 81 | o273 | 107 | 0132
22 | 24539 | 4 | 5876 | 30 | 1773 | 56 | 0635 | & | 0265 | 108 | 0.129 E : I 10%0
21 | 2312 | s 559 | 31 | 1688 | 57 | oe12 | &3 | o257 | 108 | oa2s i i
20 | 21776 | & 532 32 | 1623 | s8 | o059 | 84 | o248 | 110 | 0122 T
19 | 20526 | 7 | so64 | 33 | 1562 | se | 057 | 8 | o242 | 111 | 012 i ™ " S
18 | 19355 | & | 4823 | 34 | 1498 | e0 | 055 | 8 | 0234 | 112 | 0117 B e - ,
=17 18.258 9 4.594 35 1.437 61 0.53 87 0.228 113 0.114 _-?i._ -
16 | 17231 | 10 | 4378 | 36 | 1379 | e2 | o512 | 88 | o221 | 114 | oam
=15 16.267 11 4.173 37 1.324 63 0.494 &9 0.215 115 0.109
14 | 15364 | 12 | 3979 | 38 | 1271 | 64 | 0477 | 90 | o208 | 116 | 0106
a3 | 14517 | 13 | 3795 [ 39 | 1201 | s | o041 | o1 [ o202 | 117 | 0104 j . — - b — —r—tr—tr—
2 | 13722 | 14 | 362 | 40 | 1172 | 66 | 0445 | 92 | oas7 | 118 | 0102
=11 12.976 15 3.455 41 1.126 &7 0.43 93 0.191 119 0.099
a0 | 12275 | 16 | 3298 | 42 | 1082 | 68 | 0416 | 94 | o1se | 120 | 0097 }
-9 11.617 17 3.15 43 1.04 69 0.402 95 0.181 121 0.095
8 | w999 | 18 | 3008 | 44 1 70 | 0389 | @6 | 0176 | 122 | ooe3
-7 10.417 19 2874 45 0.962 Tl 0.376 97 0.171 123 0.091
6 | 987 | 20 | 2747 | 46 | 0825 | 72 | 0364 | 98 | o01e7 | 124 | 0089
5 | o3se | 21 | 2626 | 47 | o089 | 73 | 0352 | 99 | oaez | 125 | 0088
VIN - LV 12 ERozman, Gkr aba,
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Breadboard vezava

Uporovna tipala

Features

W Multiturn / Cermet / Industrial / Sealed
m 5 terminal styles

W Tape and reel packaging available

W Chevron seal design

m Listed on the QPL for style RJ24 per
MIL-R-22097 and RJR24 per High-Rel
Mil-R-39035

3296 - 3/8 ” Square Trimpot® Trimming Potentiometer

m Mounting hardware available
(H-117P)

m RoHS compliant* version available

W For trimmer applications/processing
guidelines, click here

TrimPot 1 Trimer Potenciometer TSR32964104

Proizvajalec

Suntan

~GSOAE

[

TSR32962£104

Standard Resistance Table

Resistance Resistance

(Ohms) Code
Proizvajalec Suntan 10 100
20 200
Stevilka proizvajalca TSR-32967-104 .E:} m
200 2m
Upornost 100KOhm 500 501
1,000 102
Mot 0.5W g:% %
10,000 103
Toleranca +10% ED,DGD 203
25,000 253
. 50,000 503
Tip TH 100,000 104
AR AAfR A A

https://www.ic-elect.si/trimpot-cer-64z-100k-tsr-3296z.html
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Breadboard vezava Uporniki

www.resistorguide.com

Signficant figures Multiphy Tolerance Temp. Coeff. Fail Rate
Elektronske komponente (%) (ppmiK) (%)
black 0 0 0 x 1 250 (U)
brown 1 1 1 x 10 1(F) 100 (5) 1
2 2 2 x 100 2(G) 50 (R) 0.1
3 3 3 x 1K 15 (P) 0.01
: | yellow [ 4 4 4 X 10K 25 (Q) 0.001
Dioda LED 5 5 5 X 100K 0.5(D) | 20(Z)
6 6 6 X 1M 0.25 (C)| 10(2)
Flat edge 7 7 7 X 10M 0.1 (B) 5 (M)
8 8 8 X 100M | 0.05(A)| 1(K)
9 9 9 X 1G
_|_ - Shagt|  x 0.1 50)
oy o[ x 0.01 10 (K)
bands 20 (M)

CATHODE 6 band 3.21kQ 1% 50ppm/K
5 band 521Q 1%
4 band 82kQ 5%
— 3 band :)—330!2 20%

-
gap between band 3 and 4
indicates reading direction

Resistor Color Code Calculator and Chart (4-band, 5-band or 6-band)

Shorter lead
/ Z naslova kttps://www.allaboutcircuits.com/tools/resistecolorcodecalculator/>

Longer lead
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Flat edge

" S o
_I_

Breadboard vezava

CATHODE

Dioda LED
|l zral un upora za o0mej

1.5 16 1.7
YV (wolts) —
high +3 3V
Out £ é R-ﬂ L Shorter lead
MCU e ortr e
R llmA YZLLED Long 4
MCU onger lea
. ?7 LED | —
\ Out oW
Vo =V 24-16 33V, -V 3.3-16-0.4
R=_0OH_'d _ - 8000 R = é” oL _Z ~13K0
1, 0.001 I4 0.001

Z naslova kttp://users.ece.utexas.edu/~valvano/Volume1B6ok/C8 SwitchLED.htm
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Breadboard vezava

Orodja

Multimeter EMOS MD-420

BwNn =

FUNC. RANGE  MAXD  DATAR

AUTD POWER OFF

Temp 'WWUHF -

Preverjanje povezav Merjenje el. toka

A zaporedna vezava !ll

Merjenje upornosti )
A nizka upornost

Merjenje el. napetosti

A enosmerna DC Praktil|l ni nasvet.i
A vzporedna vezava Il A Vel i noma mer i mo napetos
_ isok t A upornost samo izven tokokroga
A VISOKa upornos A pazimo, da ne sklenemo kratkega stika z
merilno sondo (merjenje el. toka)
A pazimo predvsem na majhne upornosti:

A Med +V in GND
A Na izhodih, vhodih mikrokrmilnikov

https://www.emos-si.si/multimeter-md-420
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VIN projekt : TinkerCad
Breadboard vezave
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Ponovitev

it

A https://learn.sparkfun.com/tutorials/how-to-use-a-breadboard/

A https://www.sciencebuddies.org/science-fair-projects/references/how-to-use-a-breadboard
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VIN projekt : TinkerCad 7 LAB 2

Breadboard vezave i VP2 primeri vezav
\Jco \lee Vee *
$

> j‘“ B " LEV\(.» q\/

Ponovitev

Napetost - tipka Napetost - Potenciometer Napetost - tipalo Izhodni tok (C-E)

Ezals} o 0 & ©

1.65 mV o

©0
et
N
o
<
@00
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o
a
3
>
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@006

=0

e e e e ey e s s e R T

-------------------------

@0

--------------------------------------------------

https://www.tinkercad.com/things/909pEg418de
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https://www.tinkercad.com/things/9o9pEq418de

Breadboardvezavei i zhodi gli za del o

¢ AVI N BreAdBoardDe mo fi :breddboamlAmer i | nafi (napajana) vezava (za n

e .
© 1. L0R Napetost - LED

) [z2ev 1O

C] ‘1.22mA.O:
CBE e pp
'::———‘__J_—)

@ Bamilck(BE) S 4 B SSSSaRa SRS SSSaN §

e Tranzistorska stopnja

C) C) e
https://www.tinkercad.com/things/1UQpxVO

¢ AVI N BreAdBoardSTM3 2 |

GPIO Input
H = Tipka Off

L =Tipka On € anc Input

3.13V

GPIO Output
L=LED On
H = LED Off

@ Tipka @ Analogno tipalo - LDR

https://www.tinkercad.com/things/cZld7zNU6Yd
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https://www.tinkercad.com/things/1UQpxVO5DSY
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Breadboard vezaveii zhodi gli za del o

¢ AVI N BreAdBoardSTM3 2 | O D e nbeedidboard vezavaaa povezavo s STM32 sistemoma

https://www.tinkercad.com/things/cZId7zNU6Yd & < Sl
® Pt . =9
= Tipka On @ ADC Input ADC Input 793 pA U
[ 330v l [ so00v II 313V l N
U A

3.3V STM32 @

GPIO Output
L=LED On
H =LED Off

................

A
5 b B :
GND STM32
Arma allaan ARdln IZII' o J

Analogno tipalo - LDR
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Breadboardvezava-pr i po mo | ki

Flat edge
-
+
ANODE CATHODE
+
shorter lead
\_nngerlead
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Breadboard vezava

Osnovna priporolila za potek praktilneg

¢ 1. Vezava na breadboardu :
¢ Vv dvoje izvedite lastno vezavo (GPIO: tipka, led, ADC: uporovno tipalo)
¢ previdno pr ikanektogel ujte ¢gi ce,

¢ 2. Preveritev vezav (multimeter, &)

¢ zmultimetrige br ez B 8TM8B2sistenom
C preverite posamezne komponente pred ve
C po vezavi: posamezne veje, stike, povezave, upornosti med Vcc in GND

¢ preverite logiko in pravilnost povezav
¢ preverite tudi slike povezanih sistemov

¢ 3. Povezava s STM32 in programiranje: Napajanje 3V !
cCpovegit e sistem®ri (Mg B izkoplien) Prikljulite
¢ STM32: vklop in delo na STM32 programu:

¢ https://github.com/LAPSyL AB/STM32H7_Discovery VIN_Projects/tree/main/STM32H750B-DK_Breadboard_VIN

¢ Zanimivost: z multimetri preverite druge vezave
¢ Anapaj ano@AVV &zBieAdBoard De mo fi
¢ vezavo-AVI N BreadBoard STM32 | O Demo i
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https://github.com/LAPSyLAB/STM32H7_Discovery_VIN_Projects/tree/main/STM32H750B-DK_Breadboard_VIN
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" JEE
VIN projekt - VP4: STM32- CubeIDE prOJekt

breadboard vezave B e ve 2o LA et Gistine, mavertle
AOsvegitev: STI_” em

A Priprava na povezovanje

A STM32H7 CubelDE + breadboard povezave
LED, tipka, potenciometer, uporovna tipala

A DN2-VP4: Breadboard + STM32H7
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Breadboardvezava 2 mo g n i vezayvi zunanji h LETI

A: BN A B:

— Pﬁ 2, L¥D
I8 K
u "y 0FF

G
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Breadboardvezava D a | Qregdboard je lahko prekinjen na sredini !!!

Pozorna dol gi h opgogl phekenimt ev
povezave (modra, rdela I|Iinija) na pol
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Breadboard vezava i STM32H7

| z h odiViN LABreadboardSTM32H7 IO Demo

@ STM32 Board
GPIO Input
© H= Tilpkg Off O
L =Tipka On @ ADC Input @ ADC Input Q
-® 09

3.30V|e S 313V e
30V|e 3.00V|e 13V e
U &
L. ... —
oooooooo - 0K E_- P ‘- 3.3V STM32 @
s

alogno tipalo - LDR

anal ogni , 1x digital:

Povezava

PA4  Analogni Fumenaditka

: PH10 Dig. Vhod Zelena(icka
\__ PA3 Dig. Izhod LED  Crantna(icka

PJ2,Pi13 Dig. I1zhod vgr.LED diode

=\
I

i

J
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Breadboard vezava i STM32H7

| z h odiViNLABreadboardSTM32H7 IO Demo

idl &=

1
e k7]
<
L O
*
£

1 x

" Testno vezje (primenSTM

GPIO Vrsta

anal

it =hG13 Userlipka o, o -
St S 288 [y Analogni vhod  Kumehacicka \
i PH10 Dig. Vhod Zelenaika :
—22, Dg izhoden EEETENEE | _J
PJ2,Pi13 Dig. I1zhod vgr.LED diode
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Breadboard vezava i STM32H7

Prikljulitev na STM32 1x analogni, 1x digital:H

" Testno vezje (primenSTM32H7

GPIO Vrsta Povezava
PC13 UserLipka Modra t_igka
L8 B N N | L B N N N ] V----
PA4  Analogni vhod Fumenadi¢ka
PH10 Dig. Vhod Zelena(icka
\_ PA3 Dig. Izhod LED  Orantna(icka

PJ2,Pi13 Dig. I1zhod vgr.LED diode

LN \
12C4 - PD12
12C4 - PD13
Qe HO
bdl

INDJSp AC'E

TR B ey v
PWM INT'RX ' TX 'SCL'SDA 5V

o Lavn snos_
b b o™

D OloL =

(»

D00
w3

X

-

-

Y 53w
IND |

a’
aNg®

4]
=108

®ono

WNOJSP AC'S

071 909
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Breadboard vezava i STM32H7

Pri kljulitev na STM32 1x analogni ,

1x digitalni vhod, 1x digitalni izhod
" Testno vezje (primep)STM32H7

GPIO Vrsta Povezava

PC13 User tiLka Modra ti&ka
,------ ------\_ LB B ]
I PA4  Analogni vhod FumenaCi¢ka \
| P10 Dig. Vhod Zelena(i¢ka :
\__ PA3 Dig.Izhod LED Cran(naCitka J

PJ2,Pi13 Dig. I1zhod

vgr.LED diode

S
| [@ i
- Q @7
|2 o == S o
SRE Al B ?
9' [ i s N n
{3 ——HE oS AL
= obus® 2" 5 =]
R DA 5V Gt 3 B
3
[Brez naslova]
R Q = o &2 0 lee A U PO P o RN () O
5 Mikrob o
2
N e e ® @ 2
HHH — © s /%
18 ) QI g o ¥
ML
- e . L. a
i 8
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VIN projekt - VP 5 breadboard vezave

Konfiguracija 2: (PB5 DIG_OUT, PB4 DIG_INP, PA1 ADC1_IN1)

| Reset_State

DAC1_OUT1
DCMI_HSYNC
12S1_WS
12S3_WS
(o ——— LTDC_VSYNC
SPI1_NSS
SPI3_NSS o o o o e e S
SPI6_NSS
TIM5_ETR
USART2_CK
- | USB_OTG_HS_SO
GPIO_Input i
GPIO_Output T ————
GPIO_Analog
EVENTOUT
GPIO_EXTI4

S |

T EEEEEEEEEEEEEET

r------‘

" Testno vezje (primer)STM32H7

r------‘

GPIO Vrsta Povezava '— -— e - —'
PC13 User tipka Modra tipka
PA4  Analogni vhod Fumenacicka
PH10 Dig. Vhod Zelena(icka
PA3  Dig. Izhod LED  Oranlna(i¢ka
PJ2,Pil13 Dig. Izhod vgr.LED diode
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